P3Dv4.5 released

  • Hallo und guten Tag,

    habe Update mit Client Content und Scenery gemacht und habe nun das Problem, daß der P3D in gewissen Abständen auf 2 bis 4 FPS absinkt und der Aerosoft Airbus zu schlingern beginnt. Auslastung der Grafikkarte geht extrem RUNTER.

    Bitte um Hilfe.


    Lg Chris aus Wien

  • Ich habe mittlerweile den P3Dv4.5 wieder fast in dem Zustand wie Anfang Mai. Die ganze Installation hat dieses Mal aufgrund des sommerlichen Wetters ein bisschen länger gedauert - so ca. 2 Wochen.;;):D


    Weshalb ich das hier so explizit erwähne? Ich habe noch nie einen so geschmeidig laufenden P3D erlebt. Nach so einer kpl. Neuinstallation auf eine neue 1TB SSD ist das quasi so, als wenn man alle Hemmnisse über Bord geworfen hat. Alle Add-ons funktionieren einwandfrei, die Probleme der letzten Zeit sind alle weg, weshalb ich den P3D eigentlich gar nicht mehr aktivieren wollte. Ich habe moderate bis gute Einstellungen (einschl. Reflektionen im Wasser und fast alle Schatten) und fast durchweg die geblockten 30 FPS, bis auf wenige Ausnahmen. Aber unter 20 - 24 komme ich nie. Den Nvidia Inspector habe ich gar nicht mehr installiert, ich verwende nur noch die Ingame-Einstellungen, auch die Frames werden im P3D auf 30 begrenzt.


    Am liebsten würde ich jetzt gar nichts mehr weiter installieren, damit das so bleibt. (Never touch a running System)

    Gottseidank habe ich auch das 1903 Update von Win10 überstanden, welches sich arglistig im Hintergrund installierte und mich vor vollendete Tatsachen stellte.


    Ich hoffe, das bleibt jetzt erst einmal so, aber harren wir der Dinge.

    Auf jeden Fall fahre ich jetzt auch zweigleisig, was den Sim angeht (P3D und XP11) und bin damit sehr zufrieden.:)

  • Weshalb ich das hier so explizit erwähne? Ich habe noch nie einen so geschmeidig laufenden P3D erlebt.

    Auch wenn ich mich in einem anderen Beitrag gerade kritisch über die erneuerungswürdige Prepar3d-Terrain-Engine ausgelassen habe: Ich finde auch, dass die 4.5 nach dem initalen Fehlstart wirklich gut läuft. Die horrenden Ladezeiten, selbst wenn man nur Teile der Szeneriebibliothek lädt, sind z.T. drastisch verringert und damit wieder erträglich. Die Performance ist auch aus meiner Sicht deutlich besser. Ich habe zwar nicht intern auf 30 fps gelockt, verwende aber einen 30-Hz-Monitor und VSync, und in allen "normalen Szenerien" (London in TrueEarth fällt da leider nicht drunter) werden die 30 fps auch gehalten, und dies weitgehend ruckelfrei, sieht man einmal von den Nachladern ab, wenn großflächige Gebiete ins Bild kommen. Wenn die 30 fps nicht gehalten werden, wird es allerdings deutlich zittriger.


    NVI nutze ich für die 4.x gar nicht mehr, früher habe ich damit das AA verbessert, aber das ist jetzt (mit 8xSSAA) so gut, da ist der m.E. überflüssig.


    Das übrigens bei einem System, das ich seit der 4.0 nicht mehr komplett neu aufgesetzt habe, bei der 4.5 z.B. nur Client und Content aktualisiert. Und das mit Addons ziemlich vollgestopft ist, allein die Szenerien (scenery.cfg und add-on.xml zusammen 700 Einträge, die allerdings nie alle zusammen aktiv sind). Dazu UTLive und manchmal noch SkyForce/Environment Force oder Active Sky. Auch die 1903 von Windows hat mich nicht gebissen.


    Auch wenn es sich damit durchaus gut fliegen lässt, sollte das m.E. nicht darüber hinwegtäuschen, dass eine Reihe von Altlasten längst beseitigt sein müssten: Szenerie-Aufpoppen bei Scenery Distance > Medium und guter Sicht, waberndes Gelände in Bergen (mein Lieblingsfeind) bei hochauflösendem Mesh, Kaugummi-Canyons und -Fjorde, aufpoppende schwarze Gebäude, gelegentliche fliegende Häuser, um nur einige zu nennen.


    Viele Grüße, Michael

    Prepar3d4 Pro // Intel i7-6700K 4.0 GHz / Asus Z170 / Kingston 32 GB DDR4 / Samsung SSD 500 GB + SSD 1 TB + WD HD 6 TB / EVGA GTX 1080 Ti 11 GB / LG 34UM95 3440 x 1440 / Win 10/64

  • Szenerie-Aufpoppen bei Scenery Distance > Medium und guter Sicht, waberndes Gelände in Bergen (mein Lieblingsfeind) bei hochauflösendem Mesh, Kaugummi-Canyons und -Fjorde, aufpoppende schwarze Gebäude, gelegentliche fliegende Häuser, um nur einige zu nennen.

    Einiges sollte aber bei der 4.5 nicht passieren.


    Bei mir blenden sich die Gebäude smooth ein , nicht ruckartig.

    Gelände stimmt, ich fliege mit 10m als guten Kompromiss.

    Poppende schwarze Gebäude? wo? Das ist wohl eher ein Addon Fehler

    Fliegende Häuser verursacht in der Regel OrbX oder die Addon Szenerie selbst. Das ist immer ein Elevation Problem bzw. ein Problem der Ladereihenfolge intern. Hin und wider habe ich das aber auch schon gesichtet.


    Was mich wirklich noch stört ist die Stockzenerie. Wenn die überarbeitet wäre, würden sich sicher fast alle anderen Probleme selbst erschlagen.

  • Bei mir blenden sich die Gebäude smooth ein , nicht ruckartig.

    Gelände stimmt, ich fliege mit 10m als guten Kompromiss.

    Poppende schwarze Gebäude? wo? Das ist wohl eher ein Addon Fehler

    Fliegende Häuser verursacht in der Regel OrbX oder die Addon Szenerie selbst. Das ist immer ein Elevation Problem bzw. ein Problem der Ladereihenfolge intern. Hin und wider habe ich das aber auch schon gesichtet.

    Die fliegenden Häuser habe ich selbst höchst selten, andere aber öfters.


    Zum aufpoppenden Autogen: Auch das tritt nicht überall auf (in engen Tälern sicher gar nicht :)) und hängt tatsächlich von der Szenerie und den Einstellungen ab. Ich würde gern ein Video sehen, wo jemand bei guter Sicht mit einer Einstellung für Scenery/Autogen Distance über "Medium" in ORBX NCA von KSFO in etwa 3000 ft Höhe mit einer GA-Maschine nach Süden ins Silicon Valley fliegt, ohne dass etwa in Höhe Palo Alto die Häuser in Quadraten aufzupoppen beginnen. Ich habe in einer frühen Prepar3d4-Version selbst zwei Videoclips gemacht, die sind im Prepar3d-Forum noch online und von anderen verifiziert worden. Soweit ich sehe, hat sich da auch in der 4.5 nichts geändert.


    Aber wie gesagt, gottlob tritt das bei weitem nicht überall auf und scheint tatsächlich zumindest auch mit von der Szenerie abzuhängen. TrueEarth GB South mag etliche Macken haben, aber dieses Problem tritt dort trotz des Häusermeers in London kaum auf. Vielleicht liegt es ja daran, dass dort der Anteil der Autogen-Häuser relativ gering ist, was ja gerade die Performance-Probleme macht. Auch in den France-VFR-Szenerien (etwa Paris) ist es zumindest nicht so ausgeprägt.


    Aufpoppende Gebäude gibt es in dem o.g. Szenarium gleich gratis dazu, zumindest bei mir. Nur als Beispiel: Der Flugplatz Moffett Field hat einen ehemals wohl vom Militär genutzten markanten Hangar, der bei mir deutlich sichtbar schwarz aufpoppt und dann erst texturiert wird. Dasselbe Downtown San Jose.


    Viele Grüße, Michael

    Prepar3d4 Pro // Intel i7-6700K 4.0 GHz / Asus Z170 / Kingston 32 GB DDR4 / Samsung SSD 500 GB + SSD 1 TB + WD HD 6 TB / EVGA GTX 1080 Ti 11 GB / LG 34UM95 3440 x 1440 / Win 10/64

  • Wenn ich dazu komme stelle ich es mal nach. Wenn etwas in Quadraten aufpoppt liegt aber eine Überlastung vor.

    Das ist meine Erfahrung gerade nicht. Ich habe das - allerdings schon vor geraumer Zeit - einmal systematisch untersucht. Ich konnte alle möglichen Regler zurückstellen, um die CPU oder GPU zu entlasten: LOD, Mesh, Tesselation, AA was auch immer. Das Zünglein an der Waage war immer: Autogen/Scenery Distance größer oder kleiner als "Medium".


    Das stimmt auch mit der Beobachtung anderer im Lockheed-Martin-Forum überein. Natürlich ist evident, dass gar nichts mehr aufpoppt, wenn man die Autogen Building Density ganz zurückstellt, aber das kann es ja eigentlich nicht sein.;)


    Meines Erachtens ist das von LM fest codiert, möglicherweise, weil das kontinuierliche Einblenden, das ja bei "Medium" tadellos funktioniert, in weiterer Entfernung (die Anzahl einzublendender Häuser nimmt ja mit der Entfernung quadratisch zu) zu viele Ressourcen fressen würde. Clevere Designer könnten das vielleicht inzwischen umgehen oder zumindest mildern. Man darf auch nicht vergessen, dass ORBX NCA schon etliche Jahre ohne nennenswerte Änderungen auf dem Buckel hat, TrueEarth GB und France VFR Paris dagegen neu und beide nativ für Prepar3d4 entwickelt sind.


    Viele Grüße, Michael

    Prepar3d4 Pro // Intel i7-6700K 4.0 GHz / Asus Z170 / Kingston 32 GB DDR4 / Samsung SSD 500 GB + SSD 1 TB + WD HD 6 TB / EVGA GTX 1080 Ti 11 GB / LG 34UM95 3440 x 1440 / Win 10/64

  • Das ist meine Erfahrung gerade nicht. Ich habe das - allerdings schon vor geraumer Zeit - einmal systematisch untersucht. Ich konnte alle möglichen Regler zurückstellen, um die CPU oder GPU zu entlasten: LOD, Mesh, Tesselation, AA was auch immer. Das Zünglein an der Waage war immer: Autogen/Scenery Distance größer oder kleiner als "Medium".

    Ich hatte das gleiche Problem bei der Entwicklung der Slim Lights und kenne die Ursache. Es trat immer dann auf, wenn ich die OrbX Autogenlichter gelassen habe, hat aber vom Grunde her nicht nur was mit OrbX zu tun.. Dann poppten Quadrate mit Lichterketten. Meine Lichter sind Modelle. Autogen weg, kein Poppen.

    Es tritt immer dann auf, wenn starke Autogenlast auf Modelllast trifft. Modellast hat im Sim generell Vorrang und wird weit eher eingeblendet als jedes Autogen.


    Nimmst Du jetzt die Autogen Draw Distance hoch, passiert es.


    In Malta in meinem Video ist das mit Extrem Dense augetestet und passiert nicht, obwohl man 260.000 Autogengebäude und nicht gezählte Bäume sieht. Ob das so bleibt , wenn die Airportgebäude alle stehen, weiß ich noch nicht.Mit unbegrenzter Sicht fliege ich allerdings nie. Weiter als 60 km sieht Du vielleicht an 10 Tagen im Jahr.


    Also es tritt nur auf , wenn Autogenlast und Addonlast extrem zusammen kommen.

    Deswegen nützt es auch nichts andere Regler als die Autogenregler zurück zu nehmen, denn die Modelle werden trotzdem geladen.

    Du kannst nur das Autogen in der Entfernung begrenzen. Das wird auch keiner ändern.