Crash to Desktop bei mehr als 30 FPS

  • Wenn ich bei mir in der NVIDIA Systemsteuerung unter 3D Einstellungen die maximale Bildfrequenz nicht auf 30 begrenze stürzt der MSFS immer nach 10-20 Minuten ab. Das ist von Anfang an so und hat sich nicht geändert. Ich hatte alle Tips die ich im Internet fand ausprobiert aber das einzige was half war die Begrenzung der FPS. Auch Updates vom MSFS, Win 10, Bios, und Grafiktreibern haben daran nichts geändert.

    Ich kann zwar auch mit den 30 FPS erstmal leben aber würde das Problem auf Dauer gerne beseitigen.

    Ab und zu gibt es aber trotz der FPS-Begrenzung noch CTDs.

    Meine Grafikkarte GTX 1070 ist ja auch nicht mehr die aktuellste aber ich will mir im Moment keine neue kaufen.

    Vielleicht hat hier im Forum noch jemand eine Lösung für das Problem.


    Herzliche Grüße
    Christian

    Mainboard: Asus / Maximus VIII Hero; CPU: i7-6700K @ 4 GHz;Memory: DDR 4 / 32 GBytes; GPU: NVIDIA GEFORCE GTX 1070 / 8 GB GDDR5; Betriebssystem: Windows 10 Pro / 20H2 / 64-Bit Flugsimulatoren: FS98, FS2000, FS2004, FSX, X-Plane 11, P3D, MSFS; Steuerung: Honeycomb - Alpha Flight Controls, Honeycomb - Bravo Throttle Quadrant, CH Products Pro Pedals, Thrustmaster - TCA Sidestick Airbus Edition

  • Ab und zu gibt es aber trotz der FPS-Begrenzung noch CTDs.

    Dann liegt es wohl noch an anderen Dingen.

    Ich hatte anfangs auch hin und wieder mal einen CTD, bis ich den KI-Verkehr augestellt habe.

    Mitlerweile habe ich Live-Verkehr an und bisher noch keinen CDT gehabt.

    Aber versuche doch mal den Verkehr auszuschalten, hat zumindest bei mir geholfen.

    Hardware:

    Ryzen 9 3900X, ASUS RTX 2070 Super O8G Evo, G.SKiLL 16GB RAM, 1TB SSD, 4TB HDD, 600 Watt Netzteil 80+ Gold

    Logitech Extreme 3D Pro Joystick


    Mit freundlichen Grüßen,


    Denis :)

  • Für mich klingt das eher nach einem Temperaturproblem.

    Schon mal in diese Richtung gesucht?

    Gruß, Markus.


    CPU: AMD Ryzen 9 3900x

    VGA: RTX 2080 Super

    RAM: 32 GB

    Storage: 1 TB SSD

    Output: Samsung TV 4K 65" / Oculus Rift S

    Input: Saitek X56 HOTAS, Thrustmaster Pedals, Streamdeck (15), Razer Naga Trinity Maus

    FS-Kennung: MS 9766 / FS-Name: Fluchtwagen1

  • Hab jetzt mal das Tool "RealTemp" laufen lassen.
    Messung mit 30 FPS Begrenzung: CPU max 68 °C GPU max 57°C.

    Messung ohne FPS Begrenzung: CPU max 68 °C GPU max 62°C.

    Komischerweise ist der MSFS bei der Messung bei unbegrenzter FPS diesmal nicht abgestürzt.

    Ich werde demnächst nochmal testen bis er abstürzt und dann mal die Temperaturen ansehen.


    Herzliche Grüße

    Christian

    Mainboard: Asus / Maximus VIII Hero; CPU: i7-6700K @ 4 GHz;Memory: DDR 4 / 32 GBytes; GPU: NVIDIA GEFORCE GTX 1070 / 8 GB GDDR5; Betriebssystem: Windows 10 Pro / 20H2 / 64-Bit Flugsimulatoren: FS98, FS2000, FS2004, FSX, X-Plane 11, P3D, MSFS; Steuerung: Honeycomb - Alpha Flight Controls, Honeycomb - Bravo Throttle Quadrant, CH Products Pro Pedals, Thrustmaster - TCA Sidestick Airbus Edition

  • Hallo Christian,

    die Temperaturen sehen doch gut aus. Sollte also nicht daran liegen.

    Wenn Du Add-Ons im Community-Ordner liegen hast, nimm die einmal dort weg.

    Den 'Rolling-Cache' schon einmal gelöscht?

    Die 'content.xml' schon einmal umbenannt?

    Baut der SIM beim nächsten Start dann wieder auf.

    Wenn bei dir die CTD's auftauchen, bist Du dann immer in etwa an der gleichen Stelle?

    Hatte ich schon einmal, von Dortmund nach Münster/Osnabrück. Irgendwann hatte sich das dann erledigt. Müssen wohl die Daten gefixt haben.

    H.W. (Hohen Wirkungsgrad)

    Wolfgang (EDVY)


    Board: Asus ROG Maximus X Code; CPU: Intel Core i7-8700K; RAM: Corsair Vengeance 16GB

    Grafikkarte: GeForce GTX 1070 8 GB; SSD: Samsung SSD 960 PRO 512GB; Samsung SSD 860 EVO 1TB

    Monitor: Samsung C34J791WTU (Simulator); Samsung C32HG7xQQ (Karte)

    Steuerung: Saitek/Logitech G940; Multi-, Radio-, SwitchPanel; Honeycomb Alpha Flight; Thustmaster TPR


    MSFS-Name: WOST53

  • wie sieht es denn mit dem Netzteil aus? Hat das genügend Reserven für die Grafikkarte unter Volllast?

    Oft ist es so dass das Netzteil zwar lt. Nennleistung ausreicht, aber an der Leistungsgrenze keine stabile Spannung mehr liefert. Da reichen schon kleine Ausreißer um die Grafikkarte aus dem Takt zu bringen.

    Das Problem kann auch aus Alterung der Bauteile entstehen.

    Vielleicht ist das Netzteil auch nur innen verstaubt und wird nicht mehr richtig gekühlt.

    Gruß


    Jörg


    AMD Ryzen 9 3900X, 32GB RAM, Geforce RTX 3090, 1 TB SSD, Netzteil Corsair 850 W, VKB Gladiator NXT

  • ich gebe ja grundsätzlich allen Vorrednern recht. Aber bei diesem Spiel ist nicht unbedingt die Hardware an allem schuld. Sollte bei anderen Spielen kein Crash vorkommen, so würde ich einfach abwarten bis ASOBO eine stabile Version veröffentlicht. Siehe #4.

  • Mir scheint es auch so als ob es nicht an der Hardware liegt. In anderen Spielen oder Flugsimulatoren habe ich solche Probleme nicht. An meinem Netzteil "be quiet! Dark Power Pro P11 750W" liegt es wohl auch nicht denn meine Grafikkarte verbraucht nur 150 Watt. Die Abstürze hatte ich auch schon direkt nach der instalation des MSFS bevor ich Addons instaliert hatte. Ich habe nur eine Scenery und zwei payware-Flugzeuge im Community-Ordner und es auch schon ohne probiert. Die Abstürze treten unabhängig von der Region auf wo ich fliege. Den Rolling Cache und die Content.xml habe ich noch nicht gelöscht. Das könnte ich nochmal testen.

    Ansonsten muss ich eben mit der Frameratebegrenzung leben. Das ist auch nicht so schlimm denn meine Grafikkarte schafft ja sowieso nicht viel mehr FPS. Trotzdem wäre mir natürlich ein stabiler MSFS der nicht zufällig mal abstürzt lieber.


    Herzliche Grüße

    Christian

    Mainboard: Asus / Maximus VIII Hero; CPU: i7-6700K @ 4 GHz;Memory: DDR 4 / 32 GBytes; GPU: NVIDIA GEFORCE GTX 1070 / 8 GB GDDR5; Betriebssystem: Windows 10 Pro / 20H2 / 64-Bit Flugsimulatoren: FS98, FS2000, FS2004, FSX, X-Plane 11, P3D, MSFS; Steuerung: Honeycomb - Alpha Flight Controls, Honeycomb - Bravo Throttle Quadrant, CH Products Pro Pedals, Thrustmaster - TCA Sidestick Airbus Edition

  • Ist schwierig, so von außen einzuschätzen, aber ich bin immer noch beim Temperaturproblem.

    Als Elektroniker muss ich dir sagen, dass du diese Ursache noch nicht zu 100% falsifiziert hast.

    Du hast eine Temperaturmessung gemacht und gesehen, dass er mit mehr Frames definitiv wärmer wird.

    Allerdings ist er dir dabei nicht abgestürzt. Vielleicht war der Rechner bei der Messung nicht "gestresst" genug?

    Du musst immer eins nach dem anderen probieren, um diese Möglichkeiten dann ausschließen zu können.


    Ich würde jetzt 2 Dinge (mit vollen Frames) probieren:


    Leg dir die Temp-Anzeige permanent in den Vordergrund und mach mal nen richtigen Stresstest (z.B. auf KLAX).

    Wenn er abstürzt, öffnest du mal das Gehäuse, stellst nen Ventilator davor und beobachtest nochmal die Temps.
    Stürzt er dir (ohne "Stress") bei relativ niedrigen Temps ab, kannst du Temperaturprobleme endgültig ausschließen.

    Gruß, Markus.


    CPU: AMD Ryzen 9 3900x

    VGA: RTX 2080 Super

    RAM: 32 GB

    Storage: 1 TB SSD

    Output: Samsung TV 4K 65" / Oculus Rift S

    Input: Saitek X56 HOTAS, Thrustmaster Pedals, Streamdeck (15), Razer Naga Trinity Maus

    FS-Kennung: MS 9766 / FS-Name: Fluchtwagen1

  • Hallo Christian,


    wie stürzt der Rechner denn ab? Zurück zum Desktop und ohne weitere Probleme weiter nutzbar oder bootet er neu?


    In Addition zu Markus kann man sich im ersten Fall die Windows-Ereignisanzeige anzeigen lassen. Im zweiten Fall bringt das nichts und dann muss der gesamte Rechner unter Stress gesetzt werden.


    Doch dazu später mehr.


    Viele Grüße,

    Norbert

  • Also ich habe als Stresstest ohne FPS Begrenzung über KLAX gekreist nach 35 Minuten stürzte der MSFSab.

    Es krazt kurz im Sound dann friert das Bild ein und ich lande auf dem Desktop so wie immer ohne FPS Begrenzung..

    Der PC ist weiter normal benutzbar auch den MSFS kann ich anschließend wieder ohne Probleme starten.

    Mit dem Tool "RealTemp" habe ich die Temperaturen alle 5 Sekunden aufgezeichnet.

    Die Maximale Temperatur der CPU war diesesmal 61°C und der GPU war wieder 63°C.

    Warum sollte sich der MSFS einfach abschalten wenn es ihm zu warm wird?

    Ich kann mir nicht vorstellen das durch diese Temperaturen eine Software abstürzen kann.

    Wenn dann könnte ich verstehen wenn der Rechner aus Schutzgründen herunterfährt, was er aber nie gemacht hat.

    Außerdem habe ich mir mal die Windows Ereignisanzeige angeschaut und dort wurde immer folgender Fehler beim Asturz festgestellt.


    Name der fehlerhaften Anwendung: FlightSimulator.exe, Version: 0.0.0.0, Zeitstempel: 0x60420f33

    Name des fehlerhaften Moduls: VCRUNTIME140.dll, Version: 14.28.29231.0, Zeitstempel: 0x5f4c66c9

    Ausnahmecode: 0xc0000005

    Fehleroffset: 0x0000000000001550

    ID des fehlerhaften Prozesses: 0x6b0

    Startzeit der fehlerhaften Anwendung: 0x01d72a49847c7162

    Pfad der fehlerhaften Anwendung: C:\Program Files\WindowsApps\Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe\FlightSimulator.exe

    Pfad des fehlerhaften Moduls: C:\Program Files\WindowsApps\Microsoft.VCLibs.140.00.UWPDesktop_14.0.29231.0_x64__8wekyb3d8bbwe\VCRUNTIME140.dll

    Berichtskennung: 1eea433a-60c3-4d92-9966-e69998b681fe

    Vollständiger Name des fehlerhaften Pakets: Microsoft.FlightSimulator_1.14.6.0_x64__8wekyb3d8bbwe

    Anwendungs-ID, die relativ zum fehlerhaften Paket ist: App


    In anderen Foren berichten viele über die gleiche Fehlermeldung beim Absturz.

    Einige empfehlen dort Visual C ++ vc_redist.x64 und vc_redist.x32 neu zu installieren was aber bei den meisten auch nicht geholfen hat.
    Das hatte ich letztes Jahr auch schon gelesen und mal getestet. Aber das hatte bei mir auch nicht geholfen.
    Vielleicht werde ich demnächst nochmal die neueste Version instalieren.


    Herzliche Grüße

    Christian

    Mainboard: Asus / Maximus VIII Hero; CPU: i7-6700K @ 4 GHz;Memory: DDR 4 / 32 GBytes; GPU: NVIDIA GEFORCE GTX 1070 / 8 GB GDDR5; Betriebssystem: Windows 10 Pro / 20H2 / 64-Bit Flugsimulatoren: FS98, FS2000, FS2004, FSX, X-Plane 11, P3D, MSFS; Steuerung: Honeycomb - Alpha Flight Controls, Honeycomb - Bravo Throttle Quadrant, CH Products Pro Pedals, Thrustmaster - TCA Sidestick Airbus Edition

  • Moinsen Christian,


    hmm, man kann dem Flusi ja vieles nachsagen, aber CTDs durch die Software sind zur Zeit doch eher selten...

    Von daher wäre auch mein Tip, dass die Hardware da mit reinspielt:

    Deine Hardware ist ja auch, vom Alter her gesehen, doch schon etwas "abgehangen". Da können schon mal ein paar Bauteile (Spannungswandler auf dem MB, Netzteil, ...) ihre Spezifikationen verlassen. Das RAM, in dieser Grösse, hast du aber sicherlich in letzter Zeit nachgerüstet? (Markenspeicher? -- welches Timing?)

    Mein (Standard)-Vorschlag wäre: Starte prime95 als Stresstest (ggf. mit Option: "viel Speicher") und DAZU den guten alten Furmark (hier auf sinnvolle Auflösung und eingeschaltetes Anti-Aliasing achten!)

    Falls noch nicht bei dir installiert: Links auf diese Proggies findest du auch hier im Forum:-PP

    Wenn diese Kombi mindestens 8 Stunden fehlerfrei durchläuft, dann bekommst du auch von unserem "TÜV-Prüfer" Norbert Norbertus60 eine HW-Plakette, und dann müßten wir weiter schauen:yep

  • Also die Temperaturen sehen ok aus und ja, das RAM wäre noch ein Faktor.

    Ich hatte auch anfangs mal meine RAMs zu stark übertaktet, das stürzte der FS auch immer mit ab.

    Da du schreibst, dass es von Anfang an so war, schalte doch mal testweise die Taktfrequenzen im BIOS fürs RAM runter.

    Der Stresstest mit dem von Martin empfohlenen Programm halte ich auch für ne gute Idee.
    Damit könnte auch gleich ein fehlerhaftes Netzteil ausgeschlossen werden.

    Gruß, Markus.


    CPU: AMD Ryzen 9 3900x

    VGA: RTX 2080 Super

    RAM: 32 GB

    Storage: 1 TB SSD

    Output: Samsung TV 4K 65" / Oculus Rift S

    Input: Saitek X56 HOTAS, Thrustmaster Pedals, Streamdeck (15), Razer Naga Trinity Maus

    FS-Kennung: MS 9766 / FS-Name: Fluchtwagen1

  • Guten Morgen Christian,


    zur Info zu den Temperaturen: Der PC schaltet nicht automatisch ab bzw. "runter", um sich selbst zu schützen. Lediglich die GPU taktet ab einer Temp. von über 83°C runter (NVIDIA-Specs.).


    Um das RAM und die CPU auszuschließen, starte zunächst Prime95 mit der Funktion "large FFTs". RAM und CPU werden damit zu 100% ausgelastet. Läuft der Rechner nach einer Stunde noch, ist das die halbe Miete.


    Die andere Hälfte der Miete kommt mit der erweiterten Stress-Test-Durchführung gemäß den Beiträgen von Martin und Markus.


    Es könnte aber auch an einem Mieter liegen; der immer wieder Ärger macht:


    https://forums.flightsimulator…ntime140-dll-error/282497


    In der Zusammenfassung: SIM erstmal außen vor lassen, Hardware systematisch stressen, zunächst RAM & CPU, dann GPU (FurMark), dann beides (jeweils eine Stunde), wenn ok, den Mieter untersuchen.


    Edit: Siehe Stefan! Solche Programme zunächst nicht laufen lassen, SIM erneut testen.


    Viele Grüße,

    Norbert

  • Hallo,


    danke erstmal für eure Anregungen zur Fehlersuche.

    FSUIPC benutze ich nicht. Für Honeycomb - Bravo Throttle Quadrant habe ich seit Anfang Februar die "AFC_Bridge.exe" im Community Ordner. Die Absturzprobleme hatte ich aber schon vorher.

    Ich habe folgenden Arbeitspeicher seit Aufbau meines Computers Ende 2016 .: Corsair DIMM 32GB DDR4-2133 Quad-Kit. Übertaktet habe ich ihn nicht.

    Den Arbeitspeicher habe ich heute mit einem Intensivtest von Windows Speicherdiagnose(mdsched.exe) getestet.
    Der Test wurde mit folgenden Einstellungen vorgenommen.:
    Test Mix: "extendend"
    Cache: "on"

    Pass Count: 15

    Es wurden keine Probleme festgestellt.

    Außerdem habe ich wie empfohlen CPU und Arbeitspeicher mit Prime95 "large FFTs" bei 100 % Auslastung 17 Stunden ohne Fehler getestet. Dabei lag die maximale Temperatur bei 76°C.

    Des weiteren habe ich 90 Minuten gleichzeitig Prime95 "large FFTs" und FurMark mit einer Auflösung 1920x1200(8xMSAA) laufen lassen. Die Auslastung der CPU, Arbeitspeicher und GPU war dabei 100 %. Die Maximale Temperatur der CPU war 76°C und GPU 60°C. Der Test lief ohne Probleme. Den Kombitest mit Prime95 und FurMark könnte ich wie empfohlen nochmal auf 8 Stuunden ausdehnen.

    So weit erstmal meine Hardware Test's.


    Herzliche Grüße

    Christian

    Mainboard: Asus / Maximus VIII Hero; CPU: i7-6700K @ 4 GHz;Memory: DDR 4 / 32 GBytes; GPU: NVIDIA GEFORCE GTX 1070 / 8 GB GDDR5; Betriebssystem: Windows 10 Pro / 20H2 / 64-Bit Flugsimulatoren: FS98, FS2000, FS2004, FSX, X-Plane 11, P3D, MSFS; Steuerung: Honeycomb - Alpha Flight Controls, Honeycomb - Bravo Throttle Quadrant, CH Products Pro Pedals, Thrustmaster - TCA Sidestick Airbus Edition

  • Klasse gemacht :yep

    Da fällt mir jetzt hardwareseitig auch erst mal nix mehr ein...

    Gruß, Markus.


    CPU: AMD Ryzen 9 3900x

    VGA: RTX 2080 Super

    RAM: 32 GB

    Storage: 1 TB SSD

    Output: Samsung TV 4K 65" / Oculus Rift S

    Input: Saitek X56 HOTAS, Thrustmaster Pedals, Streamdeck (15), Razer Naga Trinity Maus

    FS-Kennung: MS 9766 / FS-Name: Fluchtwagen1

  • Die VCRUNTIME140.dll gehört zu Visual C++.

    Was mich wundert ist, dass der MSFS die im MSFS Verzeichnis sucht. Evtl. hast du dort keine oder auch eine zu alte Version.

    Ich würde mal die Visual C++ Runtime neu installieren. vc_redist.x64.exe

    Bin gerade nicht an meinem MSFS PC um da mal zu schauen.

    Viele Grüße


    Jürgen


    System: AMD 5950X, RTX 3080, 64 GB RAM 3200, Monitor Samsung C49RG94SSU Saitek X52 PRO, Elgato Stream Deck, 3 x Samsung NVMe 1TB SSD, 980 Pro für MSFS. Link Bilder

  • hallo Christian, welcher Virusscanner läuft auf deinem System? Bitdefender benutzt unter anderem diese ...140.dll, auch Acronis Cyper Protect, Java falls installiert.

    Grüße Stefan

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von Seppi ()

  • Moin Christian,

    ich denke inzwischen auch, dass deine HW wohl ok ist:-PP

    Als nächstes könnte man einmal Windows und die Treiber überprüfen:

    Ich würde "Cmd" als Administrator starten, dann "sfc /scannow" laufen lassen. Ev. findet der ja etwas...


    Falls das noch nichts gebracht hat:

    So, wie es aussieht, hat der MSFS seine eigene vcruntime140.dll mit im Bauch.

    Normalerweise liegt sie auch unter:

    c:\Windows\SysWOW64\vcruntime140.dll

    Wenn der Flusi startet, wird er sicher zuerst seine eigene dll finden und benutzen, da kannste die Runtime neu installieren, die wird aber wohl nur im \SysWOW64\ bzw \System32\ angelegt.

    Ein Versuch: Umbenenne doch einmal die dll im Flusi-Verzeichnis, dann müßte er die "Windows-dll" benutzen:??)


    Edit: Bin gerade wieder am Flusi-Rechner - Vergess' ganz schnell den "dll-Versuch": Die Flusi-"vcruntime140.dll" hat so ziemlich nix mit der "System-dll" zu tun...

    Von daher dürften auch alle Updates der vcruntime ins Leere laufen, da die maximal die System-dlls anfassen

    lg, Martin aus EDDV :beer

    Dieser Beitrag wurde bereits 1 Mal editiert, zuletzt von JodoL ()